#

Giao thức OSPF là gì? Đặc điểm và cách hoạt động của OSPF

 05/09/2022 - 14:00 Trịnh Duy Thanh

Giao thức OSPF là một giao thức định tuyến tiêu chuẩn, đã được sử dụng trên toàn thế giới trong nhiều năm. Nó được phần lớn các nhà cung cấp định tuyến và cộng đồng mã nguồn mở hỗ trợ.

Đây là một trong số ít các giao thức trong ngành công nghệ thông tin mà bạn có thể tin tưởng và sử dụng ở phạm vi toàn cầu.

Hãy cùng BKHOST tìm hiểu chi tiết về giao thức OSPF trong bài viết dưới đây.

Đăng ký dịch vụ Cloud VPS Pro tại BKHOST

BKHOST đang có chương trình khuyến mãi cực shock dành cho khách hàng đăng ký mới dịch vụ Cloud VPS Pro:

  • Giảm giá lên đến 30%.
  • Tặng thêm 512 MB Ram.

Đăng ký ngay hôm nay:

bảng giá thuê vps

Giao thức OSPF là gì?

Giao thuc OSPF la gi

Giao thức OSPF (Open Shortest Path First) là một giao thức định tuyến sử dụng trong một phạm vi một khu vực nhất định hoặc một hệ thống mạng. Đây là một giao thức được sử dụng phổ biến trong hệ thống mạng của các doanh nghiệp với ưu điểm nổi bật là khả năng lưu trữ thông tin nhanh chóng vào cơ sở dữ liệu.

Các bộ định tuyến (Router) giao thức OSPF dựa vào chi phí để tính toán đường dẫn ngắn nhất thông qua mạng giữa chúng và một bộ định tuyến từ xa hoặc địa chỉ mạng. Việc tính toán đường dẫn ngắn nhất được thực hiện bởi thuật toán của Djikstra.

Cách thức hoạt động của giao thức OSPF

Hoạt động của giao thức OSPF gồm 3 bước chính:

  1. Tìm kiếm và xác lập mối quan hệ với Neighor Router
  2. Trao đổi cơ sở dữ liệu LSBD
  3. Sử dụng thuật toán Djikstra để tìm ra con đường ngắn nhất.

Chúng ta sẽ cùng tìm hiểu các thuật ngữ có liên quan tới giao thức OSPF ngay sau đây.

  • Router Neighbor: Mô tả hai bộ định tuyến kết nối OSPF với nhau, chúng trao đổi thông tin về các tuyến đường và chi phí để đến đích, thuật ngữ gọi đó là NEIGHBOR.
  • AREA: Khi có nhiều bộ định tuyến được nhóm lại với nhau trong giao thức OSPF thì chúng được gọi là AREA (khu vực). Ngoại trừ các bộ định tuyến AREA biên giới, các bộ định tuyến giao thức OSPF trong một AREA này sẽ không làm hàng xóm với bộ định tuyến ở các AREA khác.
  • LSBD: Là một tấm bản đồ hệ thống mạng và bộ định tuyến dựa vào đó để tính toán định tuyến, từ đó lựa chọn ra con đường ngắn nhất. Giữa các Router trong cùng một AREA thì phải có hình ảnh chung về LSBD. Thông tin được trao đổi giữa các Router không phải là tấm bản đồ LSBD, mà là LSA (Link State Advertisement). Các đơn vị thông tin LSA được chứa trong các gói tin được gọi là LSU (Link State Update).

Các bộ định tuyến giao thức OSPF dựa vào chi phí để tính toán đường dẫn ngắn nhất thông qua mạng giữa chúng và một bộ định tuyến từ xa hoặc địa chỉ mạng. Việc tính toán đường dẫn ngắn nhất được thực hiện bởi thuật toán Djikstra. Thuật toán này không phải được thiết kế dành riêng cho giao thức OSPF, mà tình cờ nó chỉ là một thuật toán toán học ngẫu nhiên, có thể ứng dụng để kết nối mạng.

Bên cạnh đó, OSPF sử dụng chi phí làm thông số định tuyến để lựa chọn tuyến đường đi ngắn nhất trong mạng. Chính thông số này có thể được sử dụng để đánh giá chất lượng, dung lượng của đường truyền.

Chúng ta có một ví dụ đơn giản về năm bộ định tuyến được kết nối như trong sơ đồ dưới đây. Giả sử tất cả các liên kết có cùng chi phí, cách nhanh nhất để R3 kết nối với R5 là cách nào? Chính là thông qua R4 – R4 là con đường có chi phí thấp nhất. (Ví dụ, đường dẫn của R3 đến R5 qua R1, là thêm một liên kết khác và do đó phải có chi phí bổ sung).

Cach thuc hoat dong cua giao thuc OSPF
Mô tả sơ đồ kết nối giữa các bộ định tuyến

Thời kỳ sơ khai, một CPU bộ định tuyến không được trang bị hiện đại và có công nghệ mạnh mẽ như hiện nay. Có một nguyên tắc chung được đặt ra là: Một AREA OSPF không được vượt quá 50 bộ định tuyến. Điều đó sẽ giữ số lượng các tính toán đường dẫn ngắn nhất OSPF và cập nhật cơ sở dữ liệu với số lượng có thể quản lý được, khi các giao diện tăng lên hoặc giảm xuống. Chúng ta sẽ cùng tìm hiểu về giao diện trong giao thức OSPF ngay sau đây.

OSPF interfaces

Một ý tưởng quan trọng trong giao thức OSPF là: Có nhiều loại giao diện khác nhau được sử dụng để trao đổi thông tin với giao thức OSPF hàng xóm. Có quá nhiều vấn đề để thảo luận ở đây, nhưng bạn nên tập trung vào hai loại quan trọng:

  • Một giao diện Broadcast OSPF được kết nối với mạng, sẽ chia sẻ như mạng Ethernet. Từ một điểm trong hệ thống mạng, thông tin sẽ được gửi tới tất cả các điểm khác trong hệ thống.
  • Một giao diện Point-to-point OSPF là một liên kết trong đó chỉ có thể có một bộ định tuyến OSPF duy nhất ở hai đầu, chẳng hạn như liên kết WAN hoặc liên kết Ethernet được xây dựng có mục đích. Với liên kết point-to-point (PPP), hai bộ định tuyến biết chúng là bộ định tuyến giao thức OSPF duy nhất trên liên kết đó.

Lý do cho việc có nhiều loại giao diện khác nhau là để đảm bảo rằng tất cả các bộ định tuyến đều biết về các tuyến đường từ những bộ định tuyến khác.

OSPF areas

Các AREA trong giao thức OSPF, là bộ sưu tập của rất nhiều bộ định tuyến được nhóm lại với nhau. Các loại AREA xuất hiện trong OSPF gồm:

  • Backbone Area (Area 0)
  • Standard Area
  • Stub Area
  • Totally Stubby Area
  • Not so Stubby Area+

Khu vực quan trọng nhất trong OSPF là AREA Bacbone, còn được gọi là AREA 0 – Nơi các AREA OSPF bắt buộc phải đi qua để đến các AREA OSPF khác.

OSPF areas
Sơ đồ mô tả AREA 0

Ngày nay, mặc dù quy mô không phải là một lý do chính để thực hiện đa khu vực, các AREA OSPF vẫn hữu ích như ranh giới hành chính trong một mạng lưới. Ví dụ:

  • Tóm tắt và tập hợp tuyến đường (thay thế một số tuyến đường nhỏ bằng một tuyến đường lớn hơn, đơn giản hơn) chỉ có thể xảy ra tại các ranh giới AREA OSPF.
  • Không phải tất cả các bộ định tuyến cần biết về mọi tuyến đường khác có sẵn trong một mạng. Sử dụng các AREA OSPF, có thể thêm một tuyến đường mặc định đại diện cho tất cả các tuyến bên ngoài khu vực địa phương.

Hai bộ định tuyến của mạng OSPF

Dưới đây là một ví dụ về cấu hình mạng tạo ra mạng giao thức OSPF rất đơn giản giữa hai bộ định tuyến Cisco được gọi là: R1 và R2. Các bộ định tuyến được đặt trong AREA 0 và liên kết point-to-point OSPF được cấu hình giữa chúng. R1 sẽ công bố tuyến 1.1.1.1/32 và R2 sẽ công bố 2.2.2.2/32.

Hai bo dinh tuyen cua mang OSPF 
Sơ đồ mô tả cấu hình mạng tạo ra mạng giao thức OSPF

Dưới đây là hình ảnh mô tả cấu hình của R1 và R2:

Cấu hình của R1:

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet2
description OSPF Transit
ip address 10.200.1.1 255.255.255.252
! Set this interface type to be “point to point”. Put another way, there will be no “designated router” on this segment.
ip ospf network point-to-point
!
! Start an OSPF process with an ID of 200. This process number isn’t super important -- both sides do *not* have to match. The process ID distinguishes it from other OSPF processes you might be running on your router.
router ospf 200
! If you don’t set an OSPF router ID, the router will choose the highest IP of a loopback interface. If there are no loopback interfaces, the highest IP assigned to any router interface will be chosen. If you change the router ID, you’ll have to clear the OSPF process for it to become active, briefly knocking down OSPF adjacencies with neighbors.
router-id 10.200.2.1
! As OSPF neighbors communicate, details are logged. Can be helpful in troubleshooting OSPF adjacency issues.
log-adjacency-changes detail
! Place any interface with an IP address matching 1.1.1.1/32 into OSPF area 0. This line will match interface Loopback0 on this router.
network 1.1.1.1 0.0.0.0 area 0
! Place any interface with an IP address matching 10.200.1.0/30 into OSPF area 0. This line will match interface GigabitEthernet2 on this router.
network 10.200.1.0 0.0.0.3 area 0

Cấu hình của R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet2
description OSPF Transit
ip address 10.200.1.2 255.255.255.252
ip ospf network point-to-point
!
router ospf 200
router-id 10.200.1.2
log-adjacency-changes detail
network 2.2.2.2 0.0.0.0 area 0
network 10.200.1.0 0.0.0.3 area 0

Tiếp theo, để vận hành được OSPF chúng ta hãy xem một vài lệnh OSPF cơ bản có sẵn trên Cisco IOS và CLI ngay sau đây

Các lệnh OSPF cơ bản

  • Lệnh show ip ospf neighbor hiển thị IP giao thức OSPF hàng xóm và trạng thái của họ. Trong trường hợp này, chúng ta thấy R1 và R2 hoàn toàn liền kề với nhau thông qua các giao diện Gigabitethernet 2 của họ.
  • Neighbor ID là ID bộ định tuyến của hàng xóm.
  • Priority liên quan đến việc lựa chọn một bộ định tuyến được chỉ định – không quan trọng cho ví dụ đơn giản của chúng tôi.
  • Tại 1 liên kết point-to-point, state của giao thức OSPF nên ở trạng thái full nếu không có khả năng sẽ xảy ra lỗi.
  • Dead time là một bộ đếm thời gian đếm ngược liên tục, được đặt lại khi các thông tin lấy được từ hàng xóm. Nếu Dead time đếm tới 0, hàng xóm được giả định là đã chết, sự phụ thuộc bị phá hủy và liên kết bị xóa khỏi các tính toán SPF trong cơ sở dữ liệu giao thức OSPF.

Lệnh show ip ospf neighbor hiển thị IP giao thức OSPF NEIGHBOR:

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.200.1.2        0   FULL/  -        00:00:33    10.200.1.2      GigabitEthernet2
R1#

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.200.2.1        0   FULL/  -        00:00:30    10.200.1.1      GigabitEthernet2
R2#<code></code>

Khi nhìn vào bảng chuyển tiếp của thiết bị, show ip ospf neighbor chỉ hiển thị các tuyến đường đã nhập bảng chuyển tiếp qua giao thức OSPF.

Trong trường hợp này, R1 sẽ biết tuyến 2.2.2.2/32 qua OSPF, trong khi R2 sẽ biết 1.1.1.1/32 qua OSPF (Xem hình 3). Tại sao tuyến đường 10.200.1.0/30 không xuất hiện dưới dạng tuyến OSPF trên R1 hoặc R2? Bởi vì 10.200.1.0/30 cũng là một tuyến đường được kết nối.

R1#show ip route ospf
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 10.200.1.2, 00:43:45, GigabitEthernet2
R1#

R2#show ip route ospf
      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/2] via 10.200.1.1, 00:44:13, GigabitEthernet2
R2#

Hướng dẫn sử dụng giao thức OSPF hữu ích

Để nghiên cứu sâu hơn về giao thức OSPF, có lẽ bạn cần mất nhiều thời gian và công sức tìm kiếm những thông tin hữu ích qua một vài cuốn sách hoặc tham gia một khóa học chuyên sâu về giao thức này. Một số đầu sách đáng chú ý bạn có thể tìm kiếm trên Amazon như:

  • OSPF: Anatomy of an Internet Routing Protocol
  • OSPF and IS-IS: Choosing an IGP for Large-Scale Networks
  • OSPF: A Network Routing Protocol

Tổng kết về giao thức OSPF

Sự thật là, giao thức OSPF trong các hệ thống mạng lớn trở nên rất phức tạp, nó yêu cầu người quản trị phải có sự am hiểu sâu sắc về hệ thống, tốn kém trong đầu tư cơ sở hạ tầng. Tuy nhiên, không thể phủ nhận được OSPF có nhiều ưu điểm và còn là một giao thức chuẩn hóa có thể chạy rất mượt trên nhiều dòng sản phẩm đến từ nhiều hãng khác nhau. Hy vọng bài viết trên đây về giao thức OSPF đã mang lại cho các bạn một cái nhìn sơ lược về giao thức này.

Nếu bạn có thắc mắc về giao thức OSPF, hãy để lại ở bên bình luận bên dưới, BKHOST sẽ trả lời bạn trong thời gian sớm nhất.

P/s: Bạn cũng có thể truy cập vào Blog của BKHOST để đọc thêm các bài viết chia sẻ kiến thức về lập trình, quản trị mạng, website, domain, hosting, vps, server, email,… Chúc bạn thành công.


  • giao thức ospf
  • ospf là gì

Dịch vụ NVMe Hosting WordPress tốc độ cao

BKHOST đang có chương trình khuyến mãi cực tốt dành cho khách hàng đăng ký dịch vụ NVMe Hosting WordPress:

  • Giảm giá lên đến 40%.
  • Giá chỉ từ 23k/tháng.
  • Tặng gói bảo mật SSL Let’s Encrypt.

Đăng ký ngay:

wordpress hosting giá rẻ

Tôi là Trịnh Duy Thanh, CEO & Founder Công ty Cổ Phần Giải Pháp Mạng Trực Tuyến Việt Nam - BKHOST. Với sứ mệnh mang tới các dịch vụ trên Internet tốt nhất cho các cá nhân và doanh nghiệp trong nước và quốc tế, tôi luôn nỗ lực hết mình nâng cấp đầu tư hệ thống phần cứng, nâng cao chất lượng dịch vụ chăm sóc khách hàng để đem đến những sản phẩm hoàn hảo nhất cho người tiêu dùng. Vì vậy, tôi tin tưởng sẽ đem đến các giải pháp CNTT mới nhất, tối ưu nhất, hiệu quả nhất và chi phí hợp lý nhất cho tất cả các doanh nghiệp.
Bình luận

Thanh toán linh hoạt

Chúng tôi chấp nhận thanh toán như ATM, Visa, Internet Banking, Paypal, Baokim, Ngân lượng

Gọi ĐT tư vấn ngay
Chat ngay qua Zalo
Chat ngay qua Messenger
Góp ý cho chúng tôi